Noticias
Entradas
Comentarios
hacker emblem

Ya tengo mi nuevo y “flamante” DNI electrónico con el que presuntamente se pueden realizar muchas operaciones sin esperar tediosas colas.

Me ha parecido increíble lo fácil que se tiene funcionando este DNI electrónico en Ubuntu, comparado con la utilización de la tarjeta de empleo electrónica para el Servicio Andaluz de Empleo, los cuales mantienen una versión MUY antigua del Java Runtime Environment y sin esa versión, no hay uso de la tarjeta. Pero vamos al grano, que me pierdo.

Dispongo de un lector criptográfico que gratuitamente me suministraron en el SAE. En concreto, se trata del Omnikey 3121 CCID, que podéis ver mejor en la siguiente imagen:

Bueno, pues visto el hardware del que dispongo, y el DNI, claro, paso a enumerar los pasos que he seguido por si a alguien más pudiera resultarle de utilidad.

Paso 0. Instalar JRE (Java Runtime Enviroment): en este caso, si no tenemos JRE, podemos instalar el último de los repositorios, con el siguiente comando:

neonigma@neonigma-laptop:~$ sudo apt-get install sun-java6-jre

Paso 1. Instalar los drivers del lector criptográfico correspondiente: en mi caso, los drivers de Omnikey vienen con el paquete libccid, que se instala con este sencillo comando:

neonigma@neonigma-laptop:~$ sudo apt-get install libccid

Paso 2. Instalar middleware PC/SC: Es el middleware que conecta el software criptográfico con el lector de tarjetas. Se encuentra en los repositorios, así que podemos instalarlo de la siguiente forma:

neonigma@neonigma-desktop:~/descargas/sae$ sudo apt-get install pcscd pcsc-tools

Paso 3. Ahora instalamos de los repositorios opensc:

neonigma@neonigma-desktop:~$ sudo apt-get install opensc mozilla-opensc

Paso 4. Descargamos e instalamos los drivers de DNI-e:

neonigma@neonigma-desktop:~$ wget http://www.dnielectronico.es/descargas/PKCS11_para_Sistemas_Unix/Ubunt_Gutsy.tar
neonigma@neonigma-desktop:~$ tar xf Ubunt_Gutsy.tar
neonigma@neonigma-desktop:~$ sudo dpkg -i Ubunt_Gutsy/opensc-dnie_1.4.0-5_i386.deb

En este paso nos pedirán que respondamos a una serie de preguntas. Marcamos las 3 opciones que nos salen y aceptamos las dos ventanas. La última hace referencia al lugar donde se instalará el certificado para Firefox, dicha ruta es /usr/lib/opensc-pkcs11.so.

Paso 5. Reiniciar.

Paso 6. Verificar el correcto funcionamiento del DNI-e: con el DNI insertado en el lector, vamos a este enlace, pulsamos aceptar a la pregunta acerca de si queremos utilizar el certificado y comprobamos que funcione correctamente, en cuyo caso aparecerá una imagen parecida a la siguiente:

Si posees en vez de mi modelo otros lectores como el ACR38, te recomiendo la entrada que ha creado J. Félix Ontañón en este enlace.

Errores comunes

  • Alcachi nos informa de un error que podría ocurrirle a alguien con la extension de Firefox noscript instalada. En su caso el noscript hizo que no se cargase automáticamente el modulo de seguridad para el firefox. Para instalarlo manualmente lo más sencillo es cargar en el navegador la siguiente dirección:
    file:///usr/share/opensc-dnie/instal_dnie/instala_modulo.htm
    y decirle al noscript que permita ejecutar scripts en esta página.
  • julianon nos informa de que se deben instalar las versiones de los paquetes opensc que vienen en la página del dni, si se tienen instaladas o se os instalan versiones posteriores es probable que ocurran errores.

Creative Commons License Este tutorial tiene licencia CC-BY.

Referencia: AxLinux

A 9 personas les gusta esta entrada

68 Comentarios a “Cómo utilizar el DNI electrónico con Ubuntu Hardy”

  1. Jennifer dice:

    A mi no me funciona así, lo siento mucho. He seguido los pasos 3 veces y nada 🙁 desesperada ando

  2. neonigma dice:

    @Julianon: gracias por el aporte.
    @Jennifer, comencemos: ¿qué lector tienes?

  3. maria dice:

    hola al introducir el dni me pide una contraseña que no tengo puse el numero de mi dni pero nada me dice que solo me queda un intento que hagoo donde consigo la contraseña y si es posible la puedo solicitar por internet
    ayudarme
    un saludo y muchas gracias
    maria

  4. […] me ha llegado, y en un pis pas lo he configurado tanto en Mac OS X como en Linux. Ningún problema reseñable (algo de lío en OS X por mi versionitis con el OpenSC… ¡ojo […]

  5. Baban dice:

    A 54 Maria, la contraseña que te pide no es el número de dni. Si no la tienes ( te la dan en sobre cerrado cuando sacas el dni ) o no la sabes, o la quieres cambiar, o si el dnie está bloqueado, lo mas sencillo es ir a cualquier centro de expedición (cualquier comisaría) y allí tienen unos stand de dnie para el público, donde puedes cambiar tu clave, aunque no la sepas con tu huella dactilar que la máquina coteja con la que existe grabada en el dni.

  6. neonigma dice:

    Buen aporte Baban 🙂

  7. Héctor dice:

    Muchas gracias por tu tutorial!! Pero parece que me ha surgido un problema…

    Cuando voy a acceder a una web donde me pide el DNI, me sale una ventana para poner el PIN, lo pongo…no dice nada y me lo vuelve a pedir, lo vuelvo a poner, pero el lector criptográfico parece que ya no lee la tarjeta (la primera petición de PIN sí que lo hacía), y entonces, se cuelga Firefox.

    Si hago lo mismo en Preferencias, para ver el certificado, me pide el PIN, lo pongo, me lo vuelve a pedir, y ésta vez le doy a cancelar… ¡¡¡y me salen los certificados bien instalados!!! , eso sí…si vuelvo a acceder al certificado, el lector a dejado de ir.

    El Java que tengo instalado es el último de los repositorios del Ubuntu 09.10.

    No sé qué hacer ya…si tenéis alguna sugerencia os lo agradeceré.

  8. niquitonipongo dice:

    Buenas tardes. Por fin lo he conseguido. Ahora estoy con Ubuntu 10.04 y con la versión de firefox que instala por defecto (que ahora no la recuerdo); con el DNI-E y la tarjeta del SAE, cada una en un lector distinto (el primero en un Gemplus GemPC Twin SmartCard Reader y la segunda en el famoso Omnikey que entregaba el SAE), y las dos tarjetas con los dos certificados me funcionan perfectamente.
    Para la tarjeta del SAE no tuve problemas con el tutorial que aquí figuraba, pero el DNI-E si me los daba. Así que, desinstalé opensc y libopensc2 los de los repositorios oficiales, e instalé los drivers para el DNI-E de la página oficial (opensc, opensc-dnie y libopensc2, versión Ubuntu Jaunty), y en Synaptic bloqueé la versión de los dos mencionados. No tuve que añadir a firefox módulo alguno (pese a que la desinstalación fue utilizando el comando “–purge”) y lo único que comprobé es que el DNI-E, incorpora dos certificados (el de autenticación y el de firma digital), si bien por defecto, al utilizar ciertas páginas (como AEAT) siempre ubica en primer lugar el de firma, de modo que si sólo hay que utilizar el de autenticación, hay que seleccionar éste en lugar de el certificado de firma para que opere en páginas que antes daba problemas (léase la ya dicha AEAT, o bien la página de INTECO).
    Que tienes las dos tarjetas insertadas, a meter la clave de las dos tarjetas, para luego escoger el certificado que quieras usar, el del SAE o el del DNI-E.
    En otras páginas, DGT, S. Social, no tengo eses problema de distinguir el certificado de firma o el de autenticacion, pero lo importante es que puedo usar las dos tarjetas a la par.
    Espero que a alguien le sirva de ayuda.

    Un saludo.

  9. niquitonipongo dice:

    Añado más datos: cambio las tarjetas de lector y también funciona sin problemas (nada de peticiones infinitas de clave, ni otra cosa por el estilo).
    O sea que el tutorial es buenísimo, y el defecto, los dos certificados que incorpora el DNIE.

    Saludos.

  10. neonigma dice:

    ¡Ostia! (perdón por el taco)

    Muchas gracias niquitonipongo, seguiré tus nuevas instrucciones, ¡ya hacía tiempo que había dado por perdido el puñetero DNI-e con tanto cambio y tan poco tiempo para investigar!

    ¡Un saludo!

  11. niquitonipongo dice:

    ¿Taco?…tacos los que solté cuando me di cuenta de los dos tipos de certificados que “encierra” el DNI-E, máxime si tenemos en cuenta que me cargué la clave de acceso del DNI de mi mujer (ese día si que solté tacos).
    A ver si asi lo consigues.

    Un saludo.

  12. Manolo dice:

    error: ssl_error_bad_cert_alert

    Síntoma: Probando en https://av-dnie.cert.fnmt.es/compruebacert/compruebacert me salía
    “Conexión segura fallida
    Ha ocurrido un error durante una conexión a av-dnie.cert.fnmt.es.
    El otro extremo de la conexión SSL no puede verificar su certificado.
    (Código de error: ssl_error_bad_cert_alert)”

    Solución: en iceweasel (o firefox):
    – ‘Edit’ -> ‘Preferences’ -> ‘Advanced’ -> ‘Security devices’ -> ‘Load’
    – ‘Module Name’: “eDNI PKCS#11”
    – ‘Module filename’: “/usr/lib/opensc-pkcs11.so”
    – -> ‘OK’

    Bibliografía: http://fmelia.amscal.com/

  13. neonigma dice:

    Gracias por el aporte Manolo 🙂

  14. Antonio dice:

    Hola!
    Gracias por el tutorial! Con Ubuntu 10.04 y el lector N99 la cosa parece que marcha. Sin embargo, las páginas que usan java para identificarse (bancos y tal) no funcionan, como alguien ha comentado ya en algún sitio. Algunas cuelgan el firefox (4.0.1).

    ¿Alguien sabe si esto tiene remedio?

  15. niquitonipongo dice:

    Que tal, buenos días.

    Dejo un enlace para configurar dnie en ubuntu 12.04 que, la verdad sea dicha, facilita la instalcion perfectamente:

    http://bitplanet.es/manuales/3-linux/322-instalar-lector-dnie-en-ubuntu-1204.html

    Un saludo.

  16. neonigma dice:

    ¡Muchas gracias niquitonipongo!

  17. Domihost dice:

    Domihost le ofrece 1 GB de disco duro, 50 cuentas de correo, 1 base de datos,hosting trafico Ilimitado, hosting y dominio, acceso FTP y las 80 aplicaciones pre-instaladas, actualizadas siempre con la última versión del mercado. Posibilidad de la creación de Errores Personalizados.

Dejar un comentario